Wednesday, July 07, 2010

A haunting in Beaverton

For some reason my Comcast internet isn't working. Luckily I still have that Clear on auto pay. Sometimes when I set up auto pay accounts I just never un-do them when I don't need them anymore. I don't know why. I don't know why I think I can afford to pay another $25 a month for something I will never need again. Except for now, when my Comcast cable stops working. So I guess it's nice to have a backup.

Except I shouldn't NEED a backup.

Plus I think the Comcast modem is haunted. It's the only explanation I can give for the fact that, despite the fact that it is connected to NOTHING, not plugged into the cable, the computer, or the wall plug, it's still all lit up like a Christmas tree. Seriously. I could pick this modem up and walk it out to the curb RIGHT NOW and it would still be all lit up. It makes no sense. There isn't an off/on switch. But it's not connected to ANY power source WHAT SO EVER and yet, here it is, glowing brightly in my second bedroom. So when the computer suggests that, to check connectivity issues, you should unplug and turn off the modem for at least 10 seconds and then turn it all back on again, you're pretty much shit out of luck over here. So the only real explanation that fits, in my mind, is that it's haunted.

I don't have time in the morning to mess with it, and I won't have time after work either, as I have to pack a bag and go spend the night with Barbie. She had ankle surgery and her original caretaker (she needed to be completely immobile for 3 days, and had arranged a "sitter") bailed, so we are taking shifts. It kind of stresses me out, spending the night away from the kits mid-week, but what the hell, you gotta do what you gotta do. It's not Barbie's fault. And she put my happy ass up for 3 months a while back so it's not like I don't owe her. I'm just way too set in my routines.

Apparently I prefer staying with a haunted modem over her own resident ghost. They're everywhere, you know.

2 Comments:

At 2:54 PM, July 07, 2010, Blogger D. said...

Hi,

We can definitely check this out for you. I can say that the modem isn't haunted, it's more than likely has a battery in it somewhere. Shoot us an email with your account info and we'll be sure to get right on this.

Best,

Detreon Roberts
Comcast Digital Media Outreach

 
At 6:20 PM, July 07, 2010, Blogger JJ said...

Thanks Detreon! I came home from work and plugged it in again and now it's working. Apparently the ghost didn't want to stick around anymore after having been discovered.

 

Post a Comment

Links to this post:

Create a Link

<< Home